Forum of Apache users Forum Index Forum of Apache users
Discussions of software for tuning the Apache web servers
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Problem with Apache loadbalancer, j_security_check and JBoss

 
Post new topic   Reply to topic    Forum of Apache users Forum Index -> General questions
View previous topic :: View next topic  
Author Message
Sudeepthi



Joined: 26 Sep 2007
Posts: 2

PostPosted: Wed Sep 26, 2007 8:02 am    Post subject: Problem with Apache loadbalancer, j_security_check and JBoss Reply with quote

Hi,
I am using Apache load balancer using mod_jk and Jboss as a application server. Currently in my cluster i configured two Jboss servers which are running on different machines. I am using round-robin load balancer algorithm.

In my application i am using JAAS as a form based authentication. In my clustered configuration the request will be go to the server in round-robin way. I mean that if the first request goes to the first server then the second request goes to the second server and the third request goes to again first server and so on.


Now the problem is if i request for login page, the request is going to first server and the login page is displayed successfully. After entering user name and password if i submit the page, the request is going to the second server and its displaying "HTTP Status 400 - Invalid direct reference to form login page" instead of displaying the home page of my application.These configuration is done without sticky session.

I am using Apache web server 2.2.4, mod_jk 1.2.50 and JBoss 4.0.2 Application server.

Can anybody help me how to solve this issue? I am waiting for your valuable response.

Thanks & Regards,
Sudeepthi
Back to top
View user's profile Send private message
cyrosystems



Joined: 21 Nov 2007
Posts: 1

PostPosted: Wed Nov 21, 2007 3:50 am    Post subject: Try Central Director Reply with quote

Your problem is that your load balancer is not setup with or does not support sessions. If you want a quick 30 min setup with a non single point of failiure load balancer that supports sessions, check out my guide here:

http://www.cyrosystems.com/forums/viewtopic.php?f=3&t=2
Back to top
View user's profile Send private message
Sudeepthi



Joined: 26 Sep 2007
Posts: 2

PostPosted: Wed Nov 21, 2007 10:53 am    Post subject: j_security_check error Reply with quote

Thanx for the reply
Sorry we want to do the load balancing in Solaries 10.x machines
We followed the steps similiar to this link ..http://raibledesigns.com/tomcat/
But sticky_sessions in workers.properties file we mabe it 0.Thats the case we are getting j_security_error.
One solaries machine can able to autheticate properly using JAAS , means request is properly send to server
When another requset is in progess i am getting 404 error.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Forum of Apache users Forum Index -> General questions All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

Anti Bot Question MOD - phpBB MOD against Spam Bots